Back to overview
Degraded

modrinth.black is down

Feb 11 at 02:24pm MSK
Affected services
modrinth.black

Resolved
Feb 11 at 02:30pm MSK

modrinth.black recovered.

Created
Feb 11 at 02:24pm MSK

modrinth.black is degraded.