Back to overview
Degraded

modrinth.black is down

Apr 15, 2026 at 4:46am UTC
Affected services
modrinth.black

Resolved
Apr 15, 2026 at 4:51am UTC

modrinth.black recovered.

Created
Apr 15, 2026 at 4:46am UTC

modrinth.black is degraded.